Note: The other languages of the website are Google-translated. Back to English

如何在Excel中提取對角矩陣?

假設您的工作表中包含以下數據,現在您需要從數據范圍中提取對角矩陣值,如屏幕截圖所示。 曾經嘗試過從Excel中的矩陣對角線提取值嗎?

文檔提取物對角線 1

在Excel中使用公式提取對角矩陣

Office選項卡在Office中啟用選項卡式編輯和瀏覽,並使您的工作更加輕鬆...
Kutools for Excel 解決了你的大部分問題,並將你的生產力提高了 80%
  • 重用任何東西: 將最常用或最複雜的公式,圖表等添加到您的收藏夾中,並在將來快速重用它們。
  • 超過20種文字功能: 從文本字符串中提取數字; 提取或刪除部分文字; 將數字和貨幣轉換為英文單詞。
  • 合併工具:將多個工作簿和工作表合二為一; 合併多個單元格/行/列,而不會丟失數據; 合併重複的行和總和。
  • 分割工具:根據價值將數據分割成多個工作表; 一本工作簿可轉換為多個Excel,PDF或CSV文件; 一列到多列。
  • 跳過粘貼 隱藏/過濾的行; 計數與求和 按背景色; 向多個收件人批量發送個性化電子郵件。
  • 超級過濾器: 創建高級過濾方案並應用於任何工作表; 分類 按星期,日期,頻率等 篩選 用粗體,公式,註釋...
  • 超過300個強大的功能; 適用於 Office 2007-2021 和 365; 支持所有語言; 在您的企業或組織中輕鬆部署。

箭頭藍色右氣泡 在Excel中使用公式提取對角矩陣

這是一個簡單的公式,可以幫助您從矩陣範圍的對角線獲取值,請按照以下步驟操作:

1。 在數據旁邊的空白單元格中,請輸入以下公式: = INDEX(A1:E1,,ROWS($ 1:1)),請參見屏幕截圖:

文檔提取物對角線 1

2。 然後將填充手柄拖到該範圍,直到顯示錯誤值。 並且您的對角矩陣值已從左上到右下提取,如下所示:

文檔提取物對角線 1

3。 最後,您可以根據需要刪除錯誤值。

筆記:

1.論點 A1:E1 是要從中提取對角單元格值的第一行範圍,可以根據需要進行更改。

2.此公式僅適用於具有相同列號和行號的範圍單元格,例如5列和5行。


相關文章:

如何在Excel中求和範圍的對角線?


最佳辦公效率工具

Kutools for Excel 解決了你的大部分問題,並將你的生產力提高了 80%

  • 重用: 快速插入 複雜的公式,圖表 以及您以前使用過的任何東西; 加密單元 帶密碼 創建郵件列表 並發送電子郵件...
  • 超級公式欄 (輕鬆編輯多行文本和公式); 閱讀版式 (輕鬆讀取和編輯大量單元格); 粘貼到過濾範圍...
  • 合併單元格/行/列 不會丟失數據; 拆分單元格內容; 合併重複的行/列...防止細胞重複; 比較範圍...
  • 選擇重複或唯一 行; 選擇空白行 (所有單元格都是空的); 超級查找和模糊查找 在許多工作簿中; 隨機選擇...
  • 確切的副本 多個單元格,無需更改公式參考; 自動創建參考 到多張紙; 插入項目符號,複選框等...
  • 提取文字,添加文本,按位置刪除, 刪除空間; 創建和打印分頁小計; 在單元格內容和註釋之間轉換...
  • 超級濾鏡 (將過濾方案保存並應用於其他工作表); 高級排序 按月/週/日,頻率及更多; 特殊過濾器 用粗體,斜體...
  • 結合工作簿和工作表; 根據關鍵列合併表; 將數據分割成多個工作表; 批量轉換xls,xlsx和PDF...
  • 超過 300 項強大的功能. 支持 Office / Excel 2007-2021 和 365。支持所有語言。 在您的企業或組織中輕鬆部署。 完整功能 30 天免費試用。 60 天退款保證。
kte選項卡201905

Office選項卡為Office帶來了選項卡式界面,使您的工作更加輕鬆

  • 在Word,Excel,PowerPoint中啟用選項卡式編輯和閱讀,發布者,Access,Visio和Project。
  • 在同一窗口的新選項卡中而不是在新窗口中打開並創建多個文檔。
  • 將您的工作效率提高 50%,每天為您減少數百次鼠標點擊!
officetab底部
按評論排序
留言 (3)
還沒有評分。 成為第一位評論!
網站主持人對此評論進行了最小化
謝謝它的幫助! 我喜歡
網站主持人對此評論進行了最小化
嗨,請教我們如何進行逆過程。
網站主持人對此評論進行了最小化
buongiorno, purtroppo sto cercando di usare la formula di somma 在對角線 da basso a sinistra ad alto a destra

=SOMMA($D$12:F14*((RIGHE($D$12:F14)+1-RIF.RIGA($D$12:F14))=RIF.COLONNA($D$12:F14)))

in un excel in italiano... la formula però mi restituisce 0 ...è come se non verificasse mai la condizione (RIGHE($D$12:F14)+1-RIF.RIGA($D$12:F14))=RIF .COLONNA($D$12:F14) 正面
這裡還沒有評論
留下你的意見
以訪客身份發帖
×
評價此帖子:
0   字符
推薦地點

關注我們

版權所有©2009 - 萬維網。extendoffice.com。 | 版權所有。 供電 ExtendOffice。 |
Microsoft和Office徽標是Microsoft Corporation在美國和/或其他國家的商標或註冊商標。
受Sectigo SSL保護