跳到主要內容

如何在Excel中快速排行聯賽表?

眾所周知,在聯盟中,一支球隊的排名不僅取決於一個因素,還取決於三個因素:總分,進球差和進球數。 在本教程中,我將介紹如何在Excel中快速對排名表進行排名。

排名聯賽表


箭頭藍色右氣泡 排名聯賽表

例如,有一個如下所示的聯賽表,現在按照步驟一步一步對球隊進行排名。
doc排名聯賽表1

1.首先,計算每個團隊的總積分。 當獲勝者獲得2分時,請選擇一個單元格IXNUMX,然後鍵入以下公式 = C2 * 3 + D2 (C2包含獲勝次數,D2是平局),將填充手柄向下拖動到需要應用此公式的單元格上。 看截圖:
doc排名聯賽表2

2.現在對總分進行排名。 選擇單元格J2,鍵入此公式 = COUNTIF($ I $ 2:$ I $ 21,“>”&I2)+1 (I2是列表中包含總點的第一個單元格,I2:I21是總點的列表),將手柄向下拖動到所需的單元格。
doc排名聯賽表3

3.然後排列目標差。 選擇單元格K2,然後鍵入此公式 =(COUNTIF($H$2:$H$21,">"&H2)+1)/100 (H2是包含目標差的第一個單元格,H2:H21是目標差的列表),向下拖動填充手柄以填充單元格。
doc排名聯賽表4

4.在此步驟中對得分目標進行排名。 選擇單元格L2,然後鍵入公式 =(COUNTIF($F$2:$F$21,">"&F2)+1)/1000 (F2是目標得分,F2:F21是目標得分列表),將填充手柄向下拖動到單元格。
doc排名聯賽表5

5.現在將總積分排名,目標差排名和目標得分排名加在一起。 單元格M2,使用此公式 = J2 + K2 + L2 (J2,K2,L2是總積分等級,目標差等級和目標得分等級),向下拖動填充手柄以將該公式填充到單元格中。
doc排名聯賽表6

6.最後,您可以獲得聯盟球隊的排名。 選擇要放置排名的單元格,例如N2,鍵入此公式 = COUNTIF($ M $ 2:$ M $ 21,“ <”&M2)+1,(M2是總積分排名,目標差排名和目標得分排名之和的列表中的第一個單元格,而M2:M21是總積分排名,目標差排名和目標得分排名的總和的列表),拖動填充處理下來以填寫公式。
doc排名聯賽表7

無需公式即可輕鬆將數字向上或向下取整,甚至在Excel中取整

眾所周知,有些公式可以四捨五入,但是您不想使用公式四捨五入,因此Kutools for Excel的Round實用程序可以幫您一個忙。 點擊免費試用30天!
文檔輪
Kutools for Excel:擁有300多個便捷的Excel加載項,可以在30天內免費試用。
 

最佳辦公生產力工具

熱門特色: 尋找、突出顯示或識別重複項   |  刪除空白行   |  合併列或儲存格而不遺失數據   |   沒有公式的回合 ...
超級查詢: 多條件VLookup    多值VLookup  |   跨多個工作表的 VLookup   |   模糊查詢 ....
高級下拉列表: 快速建立下拉列表   |  依賴下拉列表   |  多選下拉列表 ....
欄目經理: 新增特定數量的列  |  移動列  |  切換隱藏列的可見性狀態  |  比較範圍和列 ...
特色功能: 網格焦點   |  設計圖   |   大方程式酒吧    工作簿和工作表管理器   |  資源庫 (自動文字)   |  日期選擇器   |  合併工作表   |  加密/解密單元格    按清單發送電子郵件   |  超級濾鏡   |   特殊過濾器 (過濾粗體/斜體/刪除線...)...
前 15 個工具集12 文本 工具 (添加文本, 刪除字符,...)   |   50+ 圖表 類型 (甘特圖,...)   |   40+ 實用 公式 (根據生日計算年齡,...)   |   19 插入 工具 (插入二維碼, 從路徑插入圖片,...)   |   12 轉化 工具 (數字到單詞, 貨幣兌換,...)   |   7 合併與拆分 工具 (高級合併行, 分裂細胞,...)   |   ... 和更多

使用 Kutools for Excel 增強您的 Excel 技能,體驗前所未有的效率。 Kutools for Excel 提供了 300 多種進階功能來提高生產力並節省時間。  點擊此處獲取您最需要的功能...

kte選項卡201905


Office選項卡為Office帶來了選項卡式界面,使您的工作更加輕鬆

  • 在Word,Excel,PowerPoint中啟用選項卡式編輯和閱讀,發布者,Access,Visio和Project。
  • 在同一窗口的新選項卡中而不是在新窗口中打開並創建多個文檔。
  • 將您的工作效率提高 50%,每天為您減少數百次鼠標點擊!
Comments (5)
No ratings yet. Be the first to rate!
This comment was minimized by the moderator on the site
I have created a league table but cannot figure out how to get the rankings of the teams. I tried the step by step method but stil can't get it done
This comment was minimized by the moderator on the site
ANCHE SE RIPETO TOTALMENTE LE FORMULE CHE SI MOSTRANO IN QUESTE PAGINE MI DA' SEMPRE UNA RISPOSTA DI ERRORE DELLA FORMULA MI POTRESTI DARE ALTRI SUGGERIMENTI
This comment was minimized by the moderator on the site
Jag håller på och ska anordna ett VM tips. Får dock ett problem när jag ska rangordna tabellen.

Jag har gjort alla steg enligt ovan.

1. Innan ngn match är spelad har alla ranking 1 och då står lag 2-4 som #SAKNAS!.

2. När två lag hamnar på samma ranking där lag 1 vinner med 3-1 och lag 3 vinner med 4-3. Då får de samma rankingpoäng och den ena står som #SAKNAS!
This comment was minimized by the moderator on the site
=EĞERSAY($F$3:$F$6, ">"&F3)+1)/1000 kodlar tutmuyor  
This comment was minimized by the moderator on the site
Its cuter when you do it in access
There are no comments posted here yet
Please leave your comments in English
Posting as Guest
×
Rate this post:
0   Characters
Suggested Locations