Note: The other languages of the website are Google-translated. Back to English

如何在Excel中快速排行聯賽表?

眾所周知,在聯盟中,一支球隊的排名不僅取決於一個因素,還取決於三個因素:總分,進球差和進球數。 在本教程中,我將介紹如何在Excel中快速對排名表進行排名。

排名聯賽表


箭頭藍色右氣泡 排名聯賽表

例如,有一個如下所示的聯賽表,現在按照步驟一步一步對球隊進行排名。
doc排名聯賽表1

1.首先,計算每個團隊的總積分。 當獲勝者獲得2分時,請選擇一個單元格IXNUMX,然後鍵入以下公式 = C2 * 3 + D2 (C2包含獲勝次數,D2是平局),將填充手柄向下拖動到需要應用此公式的單元格上。 看截圖:
doc排名聯賽表2

2.現在對總分進行排名。 選擇單元格J2,鍵入此公式 = COUNTIF($ I $ 2:$ I $ 21,“>”&I2)+1 (I2是列表中包含總點的第一個單元格,I2:I21是總點的列表),將手柄向下拖動到所需的單元格。
doc排名聯賽表3

3.然後排列目標差。 選擇單元格K2,然後鍵入此公式 =(COUNTIF($H$2:$H$21,">"&H2)+1)/100 (H2是包含目標差的第一個單元格,H2:H21是目標差的列表),向下拖動填充手柄以填充單元格。
doc排名聯賽表4

4.在此步驟中對得分目標進行排名。 選擇單元格L2,然後鍵入公式 =(COUNTIF($F$2:$F$21,">"&F2)+1)/1000 (F2是目標得分,F2:F21是目標得分列表),將填充手柄向下拖動到單元格。
doc排名聯賽表5

5.現在將總積分排名,目標差排名和目標得分排名加在一起。 單元格M2,使用此公式 = J2 + K2 + L2 (J2,K2,L2是總積分等級,目標差等級和目標得分等級),向下拖動填充手柄以將該公式填充到單元格中。
doc排名聯賽表6

6.最後,您可以獲得聯盟球隊的排名。 選擇要放置排名的單元格,例如N2,鍵入此公式 = COUNTIF($ M $ 2:$ M $ 21,“ <”&M2)+1,(M2是總積分排名,目標差排名和目標得分排名之和的列表中的第一個單元格,而M2:M21是總積分排名,目標差排名和目標得分排名的總和的列表),拖動填充處理下來以填寫公式。
doc排名聯賽表7

無需公式即可輕鬆將數字向上或向下取整,甚至在Excel中取整

眾所周知,有些公式可以四捨五入,但是您不想使用公式四捨五入,因此Kutools for Excel的Round實用程序可以幫您一個忙。 點擊查看 30 天免費試用!
文檔輪
Kutools for Excel:擁有超過 300 個方便的 Excel 加載項,免費試用,不受限制 30 天。
 

最佳辦公效率工具

Kutools for Excel 解決了你的大部分問題,並將你的生產力提高了 80%

  • 重用: 快速插入 複雜的公式,圖表 以及您以前使用過的任何東西; 加密單元 帶密碼 創建郵件列表 並發送電子郵件...
  • 超級公式欄 (輕鬆編輯多行文本和公式); 閱讀版式 (輕鬆讀取和編輯大量單元格); 粘貼到過濾範圍...
  • 合併單元格/行/列 不會丟失數據; 拆分單元格內容; 合併重複的行/列...防止細胞重複; 比較範圍...
  • 選擇重複或唯一 行; 選擇空白行 (所有單元格都是空的); 超級查找和模糊查找 在許多工作簿中; 隨機選擇...
  • 確切的副本 多個單元格,無需更改公式參考; 自動創建參考 到多張紙; 插入項目符號,複選框等...
  • 提取文字,添加文本,按位置刪除, 刪除空間; 創建和打印分頁小計; 在單元格內容和註釋之間轉換...
  • 超級濾鏡 (將過濾方案保存並應用於其他工作表); 高級排序 按月/週/日,頻率及更多; 特殊過濾器 用粗體,斜體...
  • 結合工作簿和工作表; 根據關鍵列合併表; 將數據分割成多個工作表; 批量轉換xls,xlsx和PDF...
  • 超過 300 項強大的功能. 支持 Office / Excel 2007-2021 和 365。支持所有語言。 在您的企業或組織中輕鬆部署。 完整功能 30 天免費試用。 60 天退款保證。
kte選項卡201905

Office選項卡為Office帶來了選項卡式界面,使您的工作更加輕鬆

  • 在Word,Excel,PowerPoint中啟用選項卡式編輯和閱讀,發布者,Access,Visio和Project。
  • 在同一窗口的新選項卡中而不是在新窗口中打開並創建多個文檔。
  • 將您的工作效率提高 50%,每天為您減少數百次鼠標點擊!
officetab底部
按評論排序
留言 (4)
還沒有評分。 成為第一位評論!
網站主持人對此評論進行了最小化
當你在訪問中這樣做時它更可愛
網站主持人對此評論進行了最小化
=EĞERSAY($F$3:$F$6, ">"&F3)+1)/1000 kodlar tutmuyor  
網站主持人對此評論進行了最小化
Jag håller på och ska anordna ett VM 提示。 Får dock ett 問題 när jag ska rangordna tabellen。

Jag har gjort alla steg enligt ovan。

1. Innan ngn match är spelad har alla 排名 1 och då står lag 2-4 som #SAKNAS!。

2. När två lag hamnar på samma 排名 där lag 1 vinner med 3-1 och lag 3 vinner med 4-3。 Då får de sammarankingpoäng och den ena står som #SAKNAS!
網站主持人對此評論進行了最小化
ANCHE SE RIPETO TOTALMENTE LE FORMULE CHE SI MOSTRANO IN QUESTE PAGINE MI DA' SEMPER UNA RISPOSTA DI ERRORE DELLA FORMULA MI POTRESTI DARE ALTRI SUGGERIMENTI
這裡還沒有評論
留下你的意見
以訪客身份發帖
×
評價此帖子:
0   字符
推薦地點

關注我們

版權所有©2009 - 萬維網。extendoffice.com。 | 版權所有。 供電 ExtendOffice。 |
Microsoft和Office徽標是Microsoft Corporation在美國和/或其他國家的商標或註冊商標。
受Sectigo SSL保護