Note: The other languages of the website are Google-translated. Back to English

如何在Excel中查找重疊的日期/時間範圍?

在本文中,我將討論如何在Excel中查找或檢查日期範圍或時間範圍是否與其他範圍重疊,如下圖所示。
doc找到重疊的datetime 1

使用公式檢查重疊的日期/時間範圍


箭頭藍色右氣泡 使用公式檢查重疊的日期/時間範圍

1.選擇開始日期單元格,轉到 名稱框 輸入名稱並按 Enter 成功為該範圍指定一個範圍名稱的關鍵。 看截圖:
doc找到重疊的datetime 2

2.然後選擇結束日期,並在 名稱框 並按下 Enter 鍵。 看截圖:
doc找到重疊的datetime 3

3.選擇要放置判斷的空白單元格,然後鍵入此公式 = SUMPRODUCT((A2 = startdate))> 2,然後將自動填充手柄向下拖動到帶有公式的單元格。 如果單元格顯示 TRUE,則表示相對日期範圍與其他日期範圍重疊,否則數據范圍與其他日期範圍不重疊。
doc找到重疊的datetime 4

在公式中,A2和B2是要檢查的日期範圍,結束日期和開始日期是在上述步驟中輸入的範圍名稱。

小費。 在某些情況下,您可能希望在日期中添加天數,如果您對快速加載項感興趣,我將介紹Kutools for Excel的 新增日期 實用程序,您可以輕鬆處理任務,如以下屏幕截圖所示。 功能齊全,不受限制 30 天, 請下載並立即免費試用。

doc添加天數

最佳辦公效率工具

Kutools for Excel 解決了你的大部分問題,並將你的生產力提高了 80%

  • 重用: 快速插入 複雜的公式,圖表 以及您以前使用過的任何東西; 加密單元 帶密碼 創建郵件列表 並發送電子郵件...
  • 超級公式欄 (輕鬆編輯多行文本和公式); 閱讀版式 (輕鬆讀取和編輯大量單元格); 粘貼到過濾範圍...
  • 合併單元格/行/列 不會丟失數據; 拆分單元格內容; 合併重複的行/列...防止細胞重複; 比較範圍...
  • 選擇重複或唯一 行; 選擇空白行 (所有單元格都是空的); 超級查找和模糊查找 在許多工作簿中; 隨機選擇...
  • 確切的副本 多個單元格,無需更改公式參考; 自動創建參考 到多張紙; 插入項目符號,複選框等...
  • 提取文字,添加文本,按位置刪除, 刪除空間; 創建和打印分頁小計; 在單元格內容和註釋之間轉換...
  • 超級濾鏡 (將過濾方案保存並應用於其他工作表); 高級排序 按月/週/日,頻率及更多; 特殊過濾器 用粗體,斜體...
  • 結合工作簿和工作表; 根據關鍵列合併表; 將數據分割成多個工作表; 批量轉換xls,xlsx和PDF...
  • 超過 300 項強大的功能. 支持 Office / Excel 2007-2021 和 365。支持所有語言。 在您的企業或組織中輕鬆部署。 完整功能 30 天免費試用。 60 天退款保證。
kte選項卡201905

Office選項卡為Office帶來了選項卡式界面,使您的工作更加輕鬆

  • 在Word,Excel,PowerPoint中啟用選項卡式編輯和閱讀,發布者,Access,Visio和Project。
  • 在同一窗口的新選項卡中而不是在新窗口中打開並創建多個文檔。
  • 將您的工作效率提高 50%,每天為您減少數百次鼠標點擊!
officetab底部
按評論排序
留言 (5)
還沒有評分。 成為第一位評論!
網站主持人對此評論進行了最小化
嗨,我正在尋找一個公式來解決以下問題。 我有具有重複休假的唯一員工 ID。 我想在“我的備註”列下突出顯示重複或重疊的葉子(開始日期和結束日期)。 感謝您的幫助。

查找附件模板供您查看。
網站主持人對此評論進行了最小化
對不起,我沒有清楚地理解你的問題。 您需要通過與下面的屏幕截圖相同的值突出顯示組?
查看附件 (1 / 5)
網站主持人對此評論進行了最小化
嗨,

我遇到了一些重疊事件的問題:我想從停機事件的時間序列中計算每個事件的非重疊分鐘數。

一個通用公式應該適用於時間事件條件的任何持續時間,例如多個事件重疊,一些,非等。到目前為止沒有問題,但是當一些隨機事件的總持續時間與單個事件重疊時,我遇到了問題通用 excel 公式的術語來計算每個事件的非重疊時間。 該工作表將是自動化的,因此我不能對每一行使用不同的公式,因為當工作表更新時,所有新的停機時間都將在其上。 這是一個例子:

如果您專門查找 12/14/2017 8:00 am 到 12/15/2017 9:00,您可以看到我的觀點。

停機時間開始(含日期) 停機時間結束(含日期)
12/14/2017 6:00 12/14/2017 7:30
12/14/2017 6:30 12/14/2017 7:30
12/14/2017 6:30 12/14/2017 16:00
12/14/2017 7:00 12/14/2017 8:15
12/14/2017 7:30 12/14/2017 8:30
12/14/2017 7:30 12/14/2017 15:00
12/14/2017 7:45 12/14/2017 8:00
12/14/2017 8:00 12/15/2017 9:00
12/14/2017 9:00 12/14/2017 10:00
12/14/2017 11:00 12/15/2017 16:00

您的幫助將不勝感激!

謝謝

GS
網站主持人對此評論進行了最小化
對不起,我不知道你的問題,你可以去我們的論壇 https://www.extendoffice.com/forum/kutools-for-excel.html,也許有人可以幫助你。
網站主持人對此評論進行了最小化
Formel ergänzen: "A2<=" statt "A2<"
=SUMMENPRODUKT((A2<=Enddatum)*(B2>=Startdatum))>1
這裡還沒有評論

關注我們

版權所有©2009 - 萬維網。extendoffice.com。 | 版權所有。 供電 ExtendOffice。 |
Microsoft和Office徽標是Microsoft Corporation在美國和/或其他國家的商標或註冊商標。
受Sectigo SSL保護