Note: The other languages of the website are Google-translated. Back to English

如何在Excel的特定行或列中查找並返回倒數第二個值?

如下圖所示,如何查找並返回表格範圍 A6:E1 的第 16 行或 B 列的倒數第二個值? 本文將向您展示實現它的方法。

使用公式在特定行或列中查找並返回倒數第二個值


使用公式在特定行或列中查找並返回倒數第二個值

如上面的截圖所示,要查找並返回表格範圍 A6:E1 的第 16 行或 B 列中的倒數第二個值,我們在本文中提供的公式可以幫助您。 請執行以下操作。

查找並返回B列中的倒數第二個值

1.選擇一個空白單元格以放置倒數第二個值,輸入公式 = INDEX(B:B,LARGE(IF(B:B <>“”,ROW(B:B)),2)) 進入編輯欄,然後按 按Ctrl + 轉移 + Enter 同時獲得結果。

備註:在公式中,B:B是您將在倒數第二個值找到的列。 您可以根據需要將其更改為任何列。

查找並返回第6行中的倒數第二個值

選擇一個空白單元格以填充行中倒數第二個值,然後輸入公式 = OFFSET($ A $ 6,0,COUNTA(6:6)-2,1,1) 進入編輯欄,然後按 Enter 獲得結果的關鍵。 看截圖:

備註:在此公式中,$ A $ 6是指定行的第一個單元格,6:6是您需要查找倒數第二個值的行號,


相關文章:


最佳辦公效率工具

Kutools for Excel 解決了你的大部分問題,並將你的生產力提高了 80%

  • 重用: 快速插入 複雜的公式,圖表 以及您以前使用過的任何東西; 加密單元 帶密碼 創建郵件列表 並發送電子郵件...
  • 超級公式欄 (輕鬆編輯多行文本和公式); 閱讀版式 (輕鬆讀取和編輯大量單元格); 粘貼到過濾範圍...
  • 合併單元格/行/列 不會丟失數據; 拆分單元格內容; 合併重複的行/列...防止細胞重複; 比較範圍...
  • 選擇重複或唯一 行; 選擇空白行 (所有單元格都是空的); 超級查找和模糊查找 在許多工作簿中; 隨機選擇...
  • 確切的副本 多個單元格,無需更改公式參考; 自動創建參考 到多張紙; 插入項目符號,複選框等...
  • 提取文字,添加文本,按位置刪除, 刪除空間; 創建和打印分頁小計; 在單元格內容和註釋之間轉換...
  • 超級濾鏡 (將過濾方案保存並應用於其他工作表); 高級排序 按月/週/日,頻率及更多; 特殊過濾器 用粗體,斜體...
  • 結合工作簿和工作表; 根據關鍵列合併表; 將數據分割成多個工作表; 批量轉換xls,xlsx和PDF...
  • 超過 300 項強大的功能. 支持 Office / Excel 2007-2021 和 365。支持所有語言。 在您的企業或組織中輕鬆部署。 完整功能 30 天免費試用。 60 天退款保證。
kte選項卡201905

Office選項卡為Office帶來了選項卡式界面,使您的工作更加輕鬆

  • 在Word,Excel,PowerPoint中啟用選項卡式編輯和閱讀,發布者,Access,Visio和Project。
  • 在同一窗口的新選項卡中而不是在新窗口中打開並創建多個文檔。
  • 將您的工作效率提高 50%,每天為您減少數百次鼠標點擊!
officetab底部
按評論排序
留言 (10)
還沒有評分。 成為第一位評論!
網站主持人對此評論進行了最小化
行做什麼?
網站主持人對此評論進行了最小化
謝謝大佬幹得好
網站主持人對此評論進行了最小化
你好,如果它不在同一行,這很好用。 我將如何在同一行中使用它? 例如,我為每週庫存的空容器和滿容器輸入了兩列。 我可以使用公式 =LOOKUP(2,1/(I7:GO7<>""),I7:GO7) 提取整列中的最後一個數據條目。 這表示第 7 行的最後一個數字條目。我將如何表示該行中倒數第二個值?
網站主持人對此評論進行了最小化
羅伯特,
正如您所提到的,帖子中提供的第二個公式可以幫您一個忙。 請應用以下公式。
=OFFSET($I$7,0,COUNTA(I7:GO7)-2,1,1)
網站主持人對此評論進行了最小化
嗨,

這真的很有幫助,謝謝 - 我如何調整這個公式來只拾取非零值?
網站主持人對此評論進行了最小化
嗨安迪,
你想達到這個結果嗎? 當第 6 行中倒數第二個值為零時,它返回一個空值。 如果是這樣,請應用以下公式。
=IF(OFFSET($A$6,0,COUNTA(6:6)-2,1,1)=0,"",OFFSET($A$6,0,COUNTA(6:6)-2,1,1))
網站主持人對此評論進行了最小化
TENHO UMA COLUNA DE A1 A A221 (VALOR VAI AVANÇANDO),EM OUTRA COLUNA O FATURAMENTO,COMO EU MOSTRO EM OUTRA CELULA O VALOR DO ANTEPENULTIMO VALOR,NO CASO QUERIA MOSTRAR O VALOR NA CELULA A220..
網站主持人對此評論進行了最小化
嗨尼爾森,

對不起,我不太明白你的問題。 所以你的意思是你在 A1:A221 中有一個值列表,並且想在另一個單元格中顯示倒數第二個值(單元格 A220)?
如果是這樣,試試這個公式:
=INDEX(A1:A221,LARGE(IF(A1:A221<>"",ROW(A1:A221)),2))
因為這是一個數組公式,所以不要忘記按 按Ctrl + 轉移 + Enter 獲得結果的鍵。
網站主持人對此評論進行了最小化
#NOME? - aparece esse erro
網站主持人對此評論進行了最小化
嗨 não funciona,

看來您使用的是葡萄牙語系統的 Excel。 嘗試按如下方式翻譯公式,看看是否可行。
=ÍNDICE(B:B;MAIOR(SE(B:B<>"";LIN(B:B));2))
這裡還沒有評論

關注我們

版權所有©2009 - 萬維網。extendoffice.com。 | 版權所有。 供電 ExtendOffice。 |
Microsoft和Office徽標是Microsoft Corporation在美國和/或其他國家的商標或註冊商標。
受Sectigo SSL保護