Note: The other languages of the website are Google-translated. Back to English

如何根據Excel中的單元格值選中復選框?

您可能知道如何根據複選框更改單元格值。 但是,您知道如何根據Excel中的單元格值自動選中一個複選框嗎? 本文將向您展示實現它的方法。

使用公式根據單元格值選中復選框
使用VBA代碼根據單元格值選中復選框


使用公式根據單元格值選中復選框

假設您希望當單元格A1中的值等於“測試”時自動選中復選框1。 請執行以下操作。

1.插入複選框(表單控件)後,選擇它並通過輸入以下內容將其鏈接到指定的單元格C2 = C2 進入公式欄。

ActiveX控件 複選框,請右鍵單擊它並選擇 氟化鈉性能 從右鍵單擊菜單中。 而在 氟化鈉性能 對話框中,輸入 連鎖細胞鏈接單元 字段,然後關閉對話框。 看截圖:

2.選擇內襯單元格(C2),然後輸入公式 = IF(A2 =“ Test”,TRUE,FALSE) 進入編輯欄,然後按 Enter 鍵。

備註:在公式中,“ A2”和“測試”是單元格以及您需要根據其自動選中復選框的單元格值。

3.在單元格A1中輸入值“測試”時,將自動選中相應的複選框。 看截圖:

注意:此公式不區分大小寫。


使用VBA代碼根據單元格值選中復選框

您可以運行以下VBA代碼,以基於Excel中的單元格值選中復選框。

1.右鍵單擊 工作表標籤 選中基於單元格值的複選框,然後單擊 查看代碼 從右鍵單擊菜單中。

2。 在裡面 Microsoft Visual Basic for Applications 窗口,請將以下VBA代碼複製並粘貼到“代碼”窗口中。

VBA代碼:根據單元格值選中復選框

Private Sub Worksheet_Change(ByVal Target As Range)
    If Range("A2").Value = "Test" Then
        ActiveSheet.CheckBoxes("Check Box 1").Value = xlOn
    Else
        ActiveSheet.CheckBoxes("Check Box 1").Value = xlOff
    End If
End Sub

備註:在代碼中,A2和Test是單元格以及您需要基於其自動選中復選框的單元格值。 複選框1是複選框的名稱。

3。 按 其他 + Q 鍵以關閉“ Microsoft Visual Basic應用程序”窗口。

在單元格A2中輸入值“測試”時,將自動選中指定的複選框。

備註:此代碼區分大小寫。

小提示: 如果您想將多個複選框批量插入選定的範圍內,可以嘗試使用 批量插入複選框 的效用 Excel的Kutools,或將多個選項按鈕與 批量插入選項按鈕 效用。 此外,您可以一次刪除所有復選框 批量刪除複選框 實用程序,如下圖所示。 你可以去 下載 Kutools for Excel! (30-天免費試用).


相關文章:


最佳辦公效率工具

Kutools for Excel 解決了你的大部分問題,並將你的生產力提高了 80%

  • 重用: 快速插入 複雜的公式,圖表 以及您以前使用過的任何東西; 加密單元 帶密碼 創建郵件列表 並發送電子郵件...
  • 超級公式欄 (輕鬆編輯多行文本和公式); 閱讀版式 (輕鬆讀取和編輯大量單元格); 粘貼到過濾範圍...
  • 合併單元格/行/列 不會丟失數據; 拆分單元格內容; 合併重複的行/列...防止細胞重複; 比較範圍...
  • 選擇重複或唯一 行; 選擇空白行 (所有單元格都是空的); 超級查找和模糊查找 在許多工作簿中; 隨機選擇...
  • 確切的副本 多個單元格,無需更改公式參考; 自動創建參考 到多張紙; 插入項目符號,複選框等...
  • 提取文字,添加文本,按位置刪除, 刪除空間; 創建和打印分頁小計; 在單元格內容和註釋之間轉換...
  • 超級濾鏡 (將過濾方案保存並應用於其他工作表); 高級排序 按月/週/日,頻率及更多; 特殊過濾器 用粗體,斜體...
  • 結合工作簿和工作表; 根據關鍵列合併表; 將數據分割成多個工作表; 批量轉換xls,xlsx和PDF...
  • 超過 300 項強大的功能. 支持 Office / Excel 2007-2021 和 365。支持所有語言。 在您的企業或組織中輕鬆部署。 完整功能 30 天免費試用。 60 天退款保證。
kte選項卡201905

Office選項卡為Office帶來了選項卡式界面,使您的工作更加輕鬆

  • 在Word,Excel,PowerPoint中啟用選項卡式編輯和閱讀,發布者,Access,Visio和Project。
  • 在同一窗口的新選項卡中而不是在新窗口中打開並創建多個文檔。
  • 將您的工作效率提高 50%,每天為您減少數百次鼠標點擊!
officetab底部
按評論排序
留言 (6)
還沒有評分。 成為第一位評論!
網站主持人對此評論進行了最小化
我正在嘗試使用該複選框在選中或為真時將特定文本顯示到另一張紙上,並在未選中或為假時保持空白。
網站主持人對此評論進行了最小化
具體來說,如果它是真的,我希望它顯示 0700-0800,如果它是假的,則顯示一個空白單元格。
網站主持人對此評論進行了最小化
Queria saber como fazer isto com mais de um parâmetro de comparação。 Por exemplo: quero que automaticamente minha célula A1 retorne o valor TRUE se e somente se outras três células B1, C1 e D1 estiverem todas com o valor TRUE (caso pelo menos uma delas esteja com o valor FALSE, a célula A1 continuará com o valor錯誤的)。 Já tentei usar várias fórmulas usando o comando IF, mas êxito。 Por 贊成,você sabe me dizer qual a fórmula certa para conseguir isto? :)
網站主持人對此評論進行了最小化
德斯科布里! 阿佩納斯烏薩爾:

=if(和(B1=true, C1=true, D1=true), true, false)
網站主持人對此評論進行了最小化
你好,

我從 Microsoft Office 本身下載了 Excel 模板。
有一列帶有復選框和復選標記。
我可以通過輸入“1”來激活複選標記,當我這樣做時,任務將設置為較淺的顏色。

但我沒有激活複選框。 它帶有顏色而不是複選標記。 我在公式欄中看到這個 =ALS(G7="";"☐";"⬛") (我認為 ALS 是 IF。我的語言設置為荷蘭語)。 我已經在搜索但沒有結果。 沒有格式控制,我也看不到任何屬性。
網站主持人對此評論進行了最小化
我可以在谷歌表中這樣做嗎?
這裡還沒有評論
留下你的意見
以訪客身份發帖
×
評價此帖子:
0   字符
推薦地點

關注我們

版權所有©2009 - 萬維網。extendoffice.com。 | 版權所有。 供電 ExtendOffice。 |
Microsoft和Office徽標是Microsoft Corporation在美國和/或其他國家的商標或註冊商標。
受Sectigo SSL保護