Note: The other languages of the website are Google-translated. Back to English

如何在Excel中查找第n個非空白單元格?

如何在Excel的列或行中查找並返回第n個非空白單元格值? 本文,我將討論一些有用的公式供您解決此任務。

從具有公式的列中查找並返回第n個非空白單元格值

從具有公式的行中查找並返回第n個非空白單元格值


箭頭藍色右氣泡 從具有公式的列中查找並返回第n個非空白單元格值

例如,我有一列數據,如下面的截圖所示,現在,我將從該列表中獲得第三個非空白單元格值。

doc find nth非空白1

請輸入以下公式: =INDEX($A$1:$A$25,SMALL(ROW($A$1:$A$25)+(100*($A$1:$A$25="")), 3))&"" 放入要輸出結果的空白單元格(例如D2),然後按 Ctrl + Shift + Enter 鍵在一起以獲得正確的結果,請參見屏幕截圖:

doc find nth非空白2

備註:在上式中 A1:A25 是您要使用的數據列表,以及數字 3 表示要返回的第三個非空白單元格值,如果要獲取第二個非空白單元格,則只需要根據需要將數字3更改為2。


箭頭藍色右氣泡 從具有公式的行中查找並返回第n個非空白單元格值

如果要連續查找並返回第n個非空白單元格的值,請按照以下公式進行操作:

輸入以下公式: =INDEX($A$1:$M$1,SMALL(IF($A$1:$M$1<>"",COLUMN($A$1:$M$1)-COLUMN($A$1)+1),4)) 放入要查找結果的空白單元格,然後按 Ctrl + Shift + Enter 鍵一起獲得結果,請參見屏幕截圖:

doc find nth非空白3

備註: 在上式中 A1:M1 是您要使用的行值,以及數字 4 是要返回的第四個非空白單元格值,如果要獲取第二個非空白單元格,則只需根據需要將數字4更改為2。


最佳辦公效率工具

Kutools for Excel 解決了你的大部分問題,並將你的生產力提高了 80%

  • 重用: 快速插入 複雜的公式,圖表 以及您以前使用過的任何東西; 加密單元 帶密碼 創建郵件列表 並發送電子郵件...
  • 超級公式欄 (輕鬆編輯多行文本和公式); 閱讀版式 (輕鬆讀取和編輯大量單元格); 粘貼到過濾範圍...
  • 合併單元格/行/列 不會丟失數據; 拆分單元格內容; 合併重複的行/列...防止細胞重複; 比較範圍...
  • 選擇重複或唯一 行; 選擇空白行 (所有單元格都是空的); 超級查找和模糊查找 在許多工作簿中; 隨機選擇...
  • 確切的副本 多個單元格,無需更改公式參考; 自動創建參考 到多張紙; 插入項目符號,複選框等...
  • 提取文字,添加文本,按位置刪除, 刪除空間; 創建和打印分頁小計; 在單元格內容和註釋之間轉換...
  • 超級濾鏡 (將過濾方案保存並應用於其他工作表); 高級排序 按月/週/日,頻率及更多; 特殊過濾器 用粗體,斜體...
  • 結合工作簿和工作表; 根據關鍵列合併表; 將數據分割成多個工作表; 批量轉換xls,xlsx和PDF...
  • 超過 300 項強大的功能. 支持 Office / Excel 2007-2021 和 365。支持所有語言。 在您的企業或組織中輕鬆部署。 完整功能 30 天免費試用。 60 天退款保證。
kte選項卡201905

Office選項卡為Office帶來了選項卡式界面,使您的工作更加輕鬆

  • 在Word,Excel,PowerPoint中啟用選項卡式編輯和閱讀,發布者,Access,Visio和Project。
  • 在同一窗口的新選項卡中而不是在新窗口中打開並創建多個文檔。
  • 將您的工作效率提高 50%,每天為您減少數百次鼠標點擊!
officetab底部
按評論排序
留言 (10)
還沒有評分。 成為第一位評論!
網站主持人對此評論進行了最小化
您好,我正在尋找列中的第三個空白行,我複制了您的公式,只是將範圍從 $A$1:$A:$25 更改為我的範圍 $D$306:$D$354。 但是當我改變範圍時,我得到#REF! 作為我的回答。 我已經轉換成一個數組,control-shift-enter。 現在我引用的單元格區域中有公式,所以這就是我得到#REF 的原因。 你的公式: =INDEX($A$1:$A$25,SMALL(ROW($A$1:$A$25)+(100*($A$1:$A$25="")), 3))&""我的公式: =INDEX($D$306:$D$354,SMALL(ROW($D$306:$D$354)+(1*($D$306:$D$354="")), 2))&""謝謝,諾埃爾
網站主持人對此評論進行了最小化
你把 1 而不是 100 因此回答是錯誤的。 請使用以下公式

INDEX($D$306:$D$354,SMALL(ROW($D$306:$D$354)+(100*($D$306:$D$354="")), 3))&"" 比 ctrl + shift +進入
網站主持人對此評論進行了最小化
嘿大家,

我有一個包含許多列和行的表。 行具有範圍名稱,以及行範圍開頭的描述/位置及其自己的範圍,例如“建築物編號”。 有多個行範圍/建築物。 每個列的頂部都有特定“建築裝配類型”的標題。 表格內容是每個特定“建築”描述/位置的每種類型“建築裝配類型”的數字數量。 可能有多達 (100) 個“建築組件類型”列標題,但我會將組件限制為每行範圍內的 (10) 個,因此每個“建築編號”中都會有許多空白單元格。 範圍。

我為每個“建築物”設置了其他匯總表,我想將非​​空白單元格數量拉到其中,以及每個“建築物”的相應標題“程序集類型”,每頁最多 (10) 個“程序集” .

我可以通過使用上面的數組公式來識別非空白單元格數量。 我遇到的問題是識別與其對應的標題。

最終,如果我可以識別“Assembly”標題,一旦我為每個“Building”識別了標題“Assembly”,我總是可以索引“Quantities”。 然後,我將能夠從我的裝配零件數據庫中查找與該“建築物”的每個“裝配”類型關聯的所有零件,並將其乘以每個裝配類型的“數量”。

希望這是因為有人可以提供幫助。
網站主持人對此評論進行了最小化
嗨,大家好!


您還可以幫我返回第二個、第三個非空白單元格的行號嗎?


請幫助我。
網站主持人對此評論進行了最小化
你好約翰,
下面的公式可以幫助你得到所有非空白單元格的行號,請試一試,謝謝!
=IFERROR(ROW(INDEX($A$1:$A$12,SMALL(INDEX(NOT(ISBLANK($A$1:$A$12))*ROW($A$1:$A$12),0),COUNTBLANK($A$1:$A$12)+ROW(A1)))),"")
查看附件 (1 / 5)
網站主持人對此評論進行了最小化
很有幫助,
儘管當我在設置為 DATE 的列中返回第 n 個非空白單元格時,返回的值顯示為數字(通用數字)。將單元格格式化為 DATE 也不會改變結果。 你能幫我一把嗎!
非常感謝
網站主持人對此評論進行了最小化
你好,設拉子,
抱歉,您可能沒有直接的公式來獲取日期格式。

如果其他人有解決方案,請在此處發表評論。
網站主持人對此評論進行了最小化
我在一個約 400 行的工作表上運行這個公式,整個數據中混合了大約 20 個空白,它工作得很好,除了當我填寫系列時,它有時會因為某種原因重複一行。 例如,它似乎認為一個值同時是第 331 個非空白值和第 332 個值。

我注意到的事情:
- 重複總是成對發生(例如 331 和 332 是重複的,333 和 334 也會是),然後它會恢復正常一段時間。
- 原始數據也有成對的空白,但不對應重複
- 前 94 行沒有重複,但之後每 33-35 行發生一次
- 似乎沒有鏈接到被複製單元格中的值
-我輸入的是數組和標準公式,功能沒有區別

作為參考,這是我的實際公式:

=INDEX('PO 原始數據'!CR:CR,SMALL(ROW('PO 原始數據'!CR:CR)+(100*('PO 原始數據'!CR:CR="")),$W2) &"")

注意 $W2 指的是一個輔助列,並在數據集被填滿時向上計數,但這只是因為當我只使用數字而不是單元格引用時我無法讓它計數。
當我用適當的數字替換該單元格引用(例如 $W2)時,結果相同。


關於我能做些什麼來解決這個問題的任何想法?
網站主持人對此評論進行了最小化
CIAO STO CERCANDO DI APPLICARE LA TUA FORMULA MA NON MI FUNZIONA,DOVE STO SBAGLIANDO?
=INDICE($K$37:$K$88;MIN(RIGHE($K$37:$K$88)+RIGHE(100*($K$37:$K$88=""));6))&""
DEVO VISUALIZZARE L'ENNESIMA RIGA DIVERSA DA VUOTO

感恩
網站主持人對此評論進行了最小化
=INDICE($K$37:$K$88;MIN(RIGHE($K$37:$K$88)+(100*($K$37:$K$88=""));6))&""
這裡還沒有評論
留下你的意見
以訪客身份發帖
×
評價此帖子:
0   字符
推薦地點

關注我們

版權所有©2009 - 萬維網。extendoffice.com。 | 版權所有。 供電 ExtendOffice。 |
Microsoft和Office徽標是Microsoft Corporation在美國和/或其他國家的商標或註冊商標。
受Sectigo SSL保護