Note: The other languages of the website are Google-translated. Back to English
登入  \/ 
x
or
x
註冊  \/ 
x

or

如果相鄰單元格在Excel中不為空,如何自動編號行?

doc自動編號(如果不為空白)1

在Excel中,我們可以拖動填充手柄以快速輕鬆地填充一列中的序列號,但是有時,我們需要根據相鄰單元格對行進行編號。 例如,如果單元格包含值,則將其編號;如果存在空白單元格,則將序列也保留為空白。 您如何解決此工作,當您在相鄰單元格中插入或刪除值時,該列可以自動重新編號,如下面的屏幕截圖所示?

如果相鄰單元格不自動用公式對行進行編號


箭頭藍色右氣泡 如果相鄰單元格不自動用公式對行進行編號


為了解決這個任務,在這裡,我將介紹一個簡單的公式,請執行以下操作:

1。 輸入以下公式: = IF(B2 <>“”,COUNTA($ B $ 2:B2),“”) 到與數據單元相鄰的空白單元中, A2(例如),然後將填充手柄向下拖動到您要應用此公式以根據相鄰單元格對列自動編號的單元格,請參見屏幕截圖:

備註:在以上公式中, B2 是您要自動編號的單元格。

doc自動編號(如果不為空白)2

2。 現在,當在空白單元格中輸入值或刪除現有數據時,A列中的序列號將自動重新編號。


最佳辦公效率工具

Kutools for Excel解決了您的大多數問題,並使您的生產率提高了80%

  • 重用: 快速插入 複雜的公式,圖表 以及您以前使用過的任何東西; 加密單元 帶密碼 創建郵件列表 並發送電子郵件...
  • 超級公式欄 (輕鬆編輯多行文本和公式); 閱讀版式 (輕鬆讀取和編輯大量單元格); 粘貼到過濾範圍...
  • 合併單元格/行/列 不會丟失數據; 拆分單元格內容; 合併重複的行/列...防止細胞重複; 比較範圍...
  • 選擇重複或唯一 行; 選擇空白行 (所有單元格都是空的); 超級查找和模糊查找 在許多工作簿中; 隨機選擇...
  • 確切的副本 多個單元格,無需更改公式參考; 自動創建參考 到多張紙; 插入項目符號,複選框等...
  • 提取文字,添加文本,按位置刪除, 刪除空間; 創建和打印分頁小計; 在單元格內容和註釋之間轉換...
  • 超級濾鏡 (將過濾方案保存並應用於其他工作表); 高級排序 按月/週/日,頻率及更多; 特殊過濾器 用粗體,斜體...
  • 結合工作簿和工作表; 根據關鍵列合併表; 將數據分割成多個工作表; 批量轉換xls,xlsx和PDF...
  • 超過300種強大功能。 支持Office / Excel 2007-2019和365。支持所有語言。 在您的企業或組織中輕鬆部署。 完整功能30天免費試用。 60天退款保證。
kte選項卡201905

Office選項卡為Office帶來了選項卡式界面,使您的工作更加輕鬆

  • 在Word,Excel,PowerPoint中啟用選項卡式編輯和閱讀,發布者,Access,Visio和Project。
  • 在同一窗口的新選項卡中而不是在新窗口中打開並創建多個文檔。
  • 每天將您的工作效率提高50%,並減少數百次鼠標單擊!
officetab底部
Say something here...
symbols left.
You are guest
or post as a guest, but your post won't be published automatically.
Loading comment... The comment will be refreshed after 00:00.
  • To post as a guest, your comment is unpublished.
    Shaiju · 7 months ago
    can we make this in arrayformula

  • To post as a guest, your comment is unpublished.
    Larry · 11 months ago
    Resolved:

    Needed to replace all the commas , with ; then formula worked.

    Thanks.
  • To post as a guest, your comment is unpublished.
    Larry · 11 months ago
    =IF(C13<>"",COUNTA($C$13:C13),"") gives error?

    There is a problem with this formula?
  • To post as a guest, your comment is unpublished.
    SAGAR · 1 years ago
    THANK YOU FOR FORMULA
  • To post as a guest, your comment is unpublished.
    Ajeet · 1 years ago
    thank you so much.
  • To post as a guest, your comment is unpublished.
    Peter · 1 years ago
    Sehr praktische Funktion, allerdings sollte man auf einer deuschsprachigen Seite auch deutschsprachige Excel-Befehle benutzen. Außerdem ist in der Formel ein Fehler. So lautet sie richtig:

    =WENN(B2<>"",ANZAHL2($B$2:B2),"")
  • To post as a guest, your comment is unpublished.
    Pankaj · 1 years ago
    As usual, exactly what I was searching for. Thanks
  • To post as a guest, your comment is unpublished.
    Tim Chen · 2 years ago
    anyway to get skip "" with this formula? i have a list with "" hidden in the cell. thanks
  • To post as a guest, your comment is unpublished.
    Eduardo Alonzo · 2 years ago
    Lol didn't know this formula existed and I did this =IF(B2<>"",(COUNTIF(B:B,"<>"&""))-(COUNTIF(B3:B501,"<>"&"")),"")
    • To post as a guest, your comment is unpublished.
      Jai · 1 years ago
      What is the use of it..