Note: The other languages of the website are Google-translated. Back to English

如果相鄰單元格在Excel中不為空,如何自動編號行?

doc自動編號(如果不為空白)1

在Excel中,我們可以拖動填充手柄以快速輕鬆地填充一列中的序列號,但是有時,我們需要根據相鄰單元格對行進行編號。 例如,如果單元格包含值,則將其編號;如果存在空白單元格,則將序列也保留為空白。 您如何解決此工作,當您在相鄰單元格中插入或刪除值時,該列可以自動重新編號,如下面的屏幕截圖所示?

如果相鄰單元格不自動用公式對行進行編號


箭頭藍色右氣泡 如果相鄰單元格不自動用公式對行進行編號

為了解決這個任務,在這裡,我將介紹一個簡單的公式,請執行以下操作:

1。 輸入以下公式: = IF(B2 <>“”,COUNTA($ B $ 2:B2),“”) 到與數據單元相鄰的空白單元中, A2(例如),然後將填充手柄向下拖動到您要應用此公式以根據相鄰單元格對列自動編號的單元格,請參見屏幕截圖:

備註:在以上公式中, B2 是您要自動編號的單元格。

doc自動編號(如果不為空白)2

2。 現在,當在空白單元格中輸入值或刪除現有數據時,A列中的序列號將自動重新編號。


最佳辦公效率工具

Kutools for Excel 解決了你的大部分問題,並將你的生產力提高了 80%

  • 重用: 快速插入 複雜的公式,圖表 以及您以前使用過的任何東西; 加密單元 帶密碼 創建郵件列表 並發送電子郵件...
  • 超級公式欄 (輕鬆編輯多行文本和公式); 閱讀版式 (輕鬆讀取和編輯大量單元格); 粘貼到過濾範圍...
  • 合併單元格/行/列 不會丟失數據; 拆分單元格內容; 合併重複的行/列...防止細胞重複; 比較範圍...
  • 選擇重複或唯一 行; 選擇空白行 (所有單元格都是空的); 超級查找和模糊查找 在許多工作簿中; 隨機選擇...
  • 確切的副本 多個單元格,無需更改公式參考; 自動創建參考 到多張紙; 插入項目符號,複選框等...
  • 提取文字,添加文本,按位置刪除, 刪除空間; 創建和打印分頁小計; 在單元格內容和註釋之間轉換...
  • 超級濾鏡 (將過濾方案保存並應用於其他工作表); 高級排序 按月/週/日,頻率及更多; 特殊過濾器 用粗體,斜體...
  • 結合工作簿和工作表; 根據關鍵列合併表; 將數據分割成多個工作表; 批量轉換xls,xlsx和PDF...
  • 超過 300 項強大的功能. 支持 Office / Excel 2007-2021 和 365。支持所有語言。 在您的企業或組織中輕鬆部署。 完整功能 30 天免費試用。 60 天退款保證。
kte選項卡201905

Office選項卡為Office帶來了選項卡式界面,使您的工作更加輕鬆

  • 在Word,Excel,PowerPoint中啟用選項卡式編輯和閱讀,發布者,Access,Visio和Project。
  • 在同一窗口的新選項卡中而不是在新窗口中打開並創建多個文檔。
  • 將您的工作效率提高 50%,每天為您減少數百次鼠標點擊!
officetab底部
按評論排序
留言 (12)
還沒有評分。 成為第一位評論!
網站主持人對此評論進行了最小化
大聲笑不知道這個公式存在,我做了這個 =IF(B2<>"",(COUNTIF(B:B,"<>"&""))-(COUNTIF(B3:B501,"<>"& "")),"")
網站主持人對此評論進行了最小化
有什麼用。。
網站主持人對此評論進行了最小化
反正用這個公式跳過“”? 我有一個列表,其中“”隱藏在單元格中。 謝謝
網站主持人對此評論進行了最小化
像往常一樣,正是我正在尋找的。 謝謝
網站主持人對此評論進行了最小化
Sehr praktische Funktion, allerdings sollte man auf einer deuschsprachigen Seite auch deutschsprachige Excel-Befehle benutzen。 Außerdemist in der Formel ein Fehler。 所以lauet sie Richtig:

=WENN(B2<>"",ANZAHL2($B$2:B2),"")
網站主持人對此評論進行了最小化
謝謝你這麼多。
網站主持人對此評論進行了最小化
謝謝你的公式
網站主持人對此評論進行了最小化
=IF(C13<>"",COUNTA($C$13:C13),"") 給出錯誤?

這個公式有問題嗎?
網站主持人對此評論進行了最小化
解決:

需要用 ; 替換所有逗號然後公式起作用了。

謝謝。
網站主持人對此評論進行了最小化
我們可以用數組公式做這個嗎
網站主持人對此評論進行了最小化
這可以用vba完成嗎?

網站主持人對此評論進行了最小化
評論 numéroter le jour de la semaine (1-7) et que ça recommence avec 1 quand lundi revient, de façon automatique。 謝謝
這裡還沒有評論
留下你的意見
以訪客身份發帖
×
評價此帖子:
0   字符
推薦地點

關注我們

版權所有©2009 - 萬維網。extendoffice.com。 | 版權所有。 供電 ExtendOffice。 |
Microsoft和Office徽標是Microsoft Corporation在美國和/或其他國家的商標或註冊商標。
受Sectigo SSL保護