跳到主要內容

如何在Excel中以範圍內的單位正確地對數字求和?

假設您具有關於每個水果的導入量的一系列數據,如下面的屏幕截圖所示,現在您希望將數字與該範圍內的單位相加。 通常,公式= SUM(range)不能正確地將數字與單位求和,但是在本教程中,我可以介紹一些好的方法來幫助您快速解決Excel中的此計算問題。

doc總和的數字,單位為1

用公式單位求和

Kutools for Excel的單位總和好主意3

與Kutools for Excel基於相同單位的總和

通過Kutools for Excel合併重複的行並求和相應的數字 好主意3


用公式單位求和

在Excel中,您可以使用公式來處理此任務。

選擇一個空白單元格,然後鍵入此公式 = SUM(SUBSTITUTE(B2:B7,“ kg”,“”)+ 0) 進去,然後按 Shift + Ctrl + 輸入 同時獲得正確的結果。

doc總和的數字,單位為2
doc箭頭
doc總和的數字,單位為3

小提示: 在上面的公式中,B2:B7是您要求和的單位的數字,kg是數據范圍內的單位,並且所有數字都必須具有相同的單位!


Kutools for Excel的單位總和

如果由於難以記住而不喜歡使用長公式來解決此工作,則可以嘗試通過應用 Kutools for Excel's 刪除字符 實用程序,然後通過一個簡單的公式對其求和。

Excel的Kutools, 與以上 300 方便的功能,使您的工作更加輕鬆。 

免費安裝 Kutools for Excel,請執行以下操作:

1.選擇與單位串聯的數字,然後單擊 庫工具 > 文本 > 刪除字符。 看截圖:

doc總和的數字,單位為13

2.然後檢查 非數值 選項僅在 刪除字符 對話。 看截圖:

doc總和的數字,單位為5

3。 點擊 Ok or 登記,並且僅保留所選單元格中的數字。 然後選擇一個空白單元格以鍵入此 = SUM(B2:B7) 計算結果的公式。 看截圖:

doc總和的數字,單位為6
doc箭頭
doc總和的數字,單位為7

與Kutools for Excel基於相同單位的總和

如果有一個包含水果,數字和不同單位的表格,如下面的屏幕截圖所示,如何基於同一單位對數字求和,例如11 Kg + 7 Kg,9磅+11磅。
doc總和的數字,單位為8

免費安裝 Kutools for Excel,請執行以下操作:

1.選擇一個單元格以放置求和結果,然後單擊 庫工具 > 公式助手 > 統計 > 基於相同文本的總和.
doc總和的數字,單位為8

2。 在裡面 公式助手 對話框,轉到 參數輸入 部分中,選擇包含數字和單位的範圍 範圍 文本框,然後選擇單位文本或基於以下內容輸入要求和的單位文本 文本 文本框。 請點擊 Ok.
doc總和的數字,單位為8

尖端:默認情況下,單元格引用在“參數”輸入部分中顯示為絕對值,如果您需要通過自動填充手柄應用公式,請將其更改為相對值。

然後得到第一個求和結果。
doc總和的數字,單位為8


通過Kutools for Excel合併重複的行並求和相應的數字

但是在某些情況下,如果您的數據范圍包含多個單位(如下圖所示),並且您希望將具有相同單位的數字相加,在這種情況下,您也可以使用 高級合併行 功能 Excel的Kutools 解決。

doc總和的數字,單位為8

免費安裝 Kutools for Excel,請執行以下操作:

1.選擇數據范圍,然後單擊 庫工具 > 合併與拆分 > 高級合併行。 看截圖:

doc總和的數字,單位為14

2。 在裡面 根據列合併行 對話框中選擇 單位 列並單擊 首要的關鍵 將其標記為主鍵。 看截圖:

doc總和的數字,單位為10

3.然後選擇 重量 包含數字的列,然後單擊 計算 > 總和。 看截圖:

doc總和的數字,單位為11

4。 點擊 Ok 現在將相同的單位相加。

doc總和的數字,單位為12


相關文章:

最佳辦公生產力工具

熱門特色: 尋找、突出顯示或識別重複項   |  刪除空白行   |  合併列或儲存格而不遺失數據   |   沒有公式的回合 ...
超級查詢: 多條件VLookup    多值VLookup  |   跨多個工作表的 VLookup   |   模糊查詢 ....
高級下拉列表: 快速建立下拉列表   |  依賴下拉列表   |  多選下拉列表 ....
欄目經理: 新增特定數量的列  |  移動列  |  切換隱藏列的可見性狀態  |  比較範圍和列 ...
特色功能: 網格焦點   |  設計圖   |   大方程式酒吧    工作簿和工作表管理器   |  資源庫 (自動文字)   |  日期選擇器   |  合併工作表   |  加密/解密單元格    按清單發送電子郵件   |  超級濾鏡   |   特殊過濾器 (過濾粗體/斜體/刪除線...)...
前 15 個工具集12 文本 工具 (添加文本, 刪除字符,...)   |   50+ 圖表 類型 (甘特圖,...)   |   40+ 實用 公式 (根據生日計算年齡,...)   |   19 插入 工具 (插入二維碼, 從路徑插入圖片,...)   |   12 轉化 工具 (數字到單詞, 貨幣兌換,...)   |   7 合併與拆分 工具 (高級合併行, 分裂細胞,...)   |   ... 和更多

使用 Kutools for Excel 增強您的 Excel 技能,體驗前所未有的效率。 Kutools for Excel 提供了 300 多種進階功能來提高生產力並節省時間。  點擊此處獲取您最需要的功能...

kte選項卡201905


Office選項卡為Office帶來了選項卡式界面,使您的工作更加輕鬆

  • 在Word,Excel,PowerPoint中啟用選項卡式編輯和閱讀,發布者,Access,Visio和Project。
  • 在同一窗口的新選項卡中而不是在新窗口中打開並創建多個文檔。
  • 將您的工作效率提高 50%,每天為您減少數百次鼠標點擊!
Comments (1)
No ratings yet. Be the first to rate!
This comment was minimized by the moderator on the site
Bonjour dans le tout 1er exercice, ce n'est pas "= SOMME (SUBSTITUT (B2: B7, "kg", "") + 0)" mais "=SOMME(SUBSTITUE(B2:B7;"kg";"")+0)". Il faut mettre des points virgules sinon message d'erreur. Merci beaucoup pour ce tuto il m'a beaucoup aidé.
There are no comments posted here yet
Please leave your comments in English
Posting as Guest
×
Rate this post:
0   Characters
Suggested Locations