跳到主要內容

如何在Excel中計算非零值的像元數?

為了計算Excel中具有非零值的單元格總數,這裡我們將向您展示兩種方法。 請瀏覽更多詳細信息。

用公式計算非零值的像元數
使用Kutools for Excel計算具有非零值的單元格數量


用公式計算非零值的像元數

假設您有一系列數據,如下圖所示。 要計算具有非零值的像元數,請執行以下操作。

1.選擇一個空白單元格以查找計數結果(此處選擇單元格H1)。 複製並粘貼公式 = COUNTIF(A1:E8,“ <> 0”)配方欄,然後按 Enter 鍵。 看截圖:

2.然後,對選定範圍的非零值總數進行計數並顯示在單元格H1中。

筆記:

1.使用以上公式,您可以計算包括空白單元格在內的非零單元格。 如果要同時忽略零單元格和空白單元格,請應用以下公式: =COUNTA(A1:D10)-COUNTIF(A1:D10,"=0"),然後按 Enter 獲得結果的關鍵,請參見屏幕截圖:

2.使用上述公式,您可以通過更改公式中的單元格引用來計算Excel中行,列或範圍中具有非零值的單元格總數。


使用Kutools for Excel計算具有非零值的單元格數量

除了公式, 選擇特定的單元格 的效用 Excel的Kutools 可以幫助您快速計算Excel中具有非零值的單元格數量。

申請前 Excel的Kutools首先下載並安裝.

1.選擇要計算非零像元數的範圍。 然後點擊 庫工具 > 選擇 > 選擇特定的單元格。 看截圖:

2.在彈出 選擇特定的單元格 對話框中選擇 細胞 ,在 選擇類型 部分,指定 不相等 ,在 特定類型 下拉列表,然後輸入數字 0 放入空白框中。 最後點擊 OK 按鈕。 看截圖:

3.然後彈出一個對話框,告訴您在選定範圍內存在多少個非零值單元格。 並且它已經直接排除了空白單元格。 點擊 OK 按鈕,將立即選擇這些單元格。

  如果您想免費試用(30天)此實用程序, 請點擊下載,然後按照上述步驟進行操作。

最佳辦公生產力工具

熱門特色: 尋找、突出顯示或識別重複項   |  刪除空白行   |  合併列或儲存格而不遺失數據   |   沒有公式的回合 ...
超級查詢: 多條件VLookup    多值VLookup  |   跨多個工作表的 VLookup   |   模糊查詢 ....
高級下拉列表: 快速建立下拉列表   |  依賴下拉列表   |  多選下拉列表 ....
欄目經理: 新增特定數量的列  |  移動列  |  切換隱藏列的可見性狀態  |  比較範圍和列 ...
特色功能: 網格焦點   |  設計圖   |   大方程式酒吧    工作簿和工作表管理器   |  資源庫 (自動文字)   |  日期選擇器   |  合併工作表   |  加密/解密單元格    按清單發送電子郵件   |  超級濾鏡   |   特殊過濾器 (過濾粗體/斜體/刪除線...)...
前 15 個工具集12 文本 工具 (添加文本, 刪除字符,...)   |   50+ 圖表 類型 (甘特圖,...)   |   40+ 實用 公式 (根據生日計算年齡,...)   |   19 插入 工具 (插入二維碼, 從路徑插入圖片,...)   |   12 轉化 工具 (數字到單詞, 貨幣兌換,...)   |   7 合併與拆分 工具 (高級合併行, 分裂細胞,...)   |   ... 和更多

使用 Kutools for Excel 增強您的 Excel 技能,體驗前所未有的效率。 Kutools for Excel 提供了 300 多種進階功能來提高生產力並節省時間。  點擊此處獲取您最需要的功能...

kte選項卡201905


Office選項卡為Office帶來了選項卡式界面,使您的工作更加輕鬆

  • 在Word,Excel,PowerPoint中啟用選項卡式編輯和閱讀,發布者,Access,Visio和Project。
  • 在同一窗口的新選項卡中而不是在新窗口中打開並創建多個文檔。
  • 將您的工作效率提高 50%,每天為您減少數百次鼠標點擊!
Comments (7)
No ratings yet. Be the first to rate!
This comment was minimized by the moderator on the site
how to count the number of cells other than 0 but not in sequential location, there is a downward gap.
This comment was minimized by the moderator on the site
Hi Yonk,

To calculate the number of non-zero cells across multiple ranges in Excel, you can try the following formula:
Assuming the areas you want to count are B41:C44, F43:F46, and H46:H47, the formula would be:
=COUNTIF(B41:C44, "<>0") + COUNTIF(F43:F46, "<>0") + COUNTIF(H46:H47, "<>0")
This comment was minimized by the moderator on the site
BRILLIANT ..searched 4 hours for this and every other expert gave me the most complicated formuals that never worked.formula: =COUNTA(A1:D10)-COUNTIF(A1:D10,"=0"),

thx you
This comment was minimized by the moderator on the site
THANK FOR YOUR INFORMATION
This comment was minimized by the moderator on the site
=CONT.SE(AL27:AL31;">0")
This comment was minimized by the moderator on the site
thanks for your efforts
This comment was minimized by the moderator on the site
Q.How to count non zero cell.
Ans. =COUNTIF(F26:Q26,">0")
There are no comments posted here yet
Please leave your comments in English
Posting as Guest
×
Rate this post:
0   Characters
Suggested Locations