Note: The other languages of the website are Google-translated. Back to English

如何計算Excel中兩個值或日期之間的單元格數量?

如果您需要計算包含兩個數字或日期之間的特定值的單元格編號,CountIf函數的公式可以快速為您提供幫助。 在本教程中,我們將向您顯示計算Excel中兩個值或日期之間的單元格數量的詳細信息。

使用CountIf函數計算兩個數字之間的單元格數目
使用CountIf函數計算兩個日期之間的單元格編號
使用Kutools for Excel(沒有公式)計算兩個值或日期之間的單元格編號


使用CountIf函數計算兩個數字之間的單元格數目

例如,您有一個工作表,其中的單元格B2:B8中具有以下數字,並且您要計算介於75和90之間的單元格數字,請執行以下操作。

計算單元格編號> X和<Y

如果要計算75到90之間的單元格數目,但不包括75到90之間的數目,則需要:

1.選擇要放入計數結果的空白單元格。 複製並粘貼公式 =COUNTIFS(B2:B8,">75", B2:B8,"<90") 進入公式欄,然後按Enter鍵。

然後,您可以立即看到所選單元格中顯示的單元格編號結果。

計算> = X和<= Y的像元數

要計算> = 75和<= 90的單元格編號,請使用以下公式 =COUNTIFS(B2:B8,">=75", B2:B8,"<=90").

1.選擇一個空白單元格以放入計數結果,將以上公式複制並粘貼到公式欄中。 然後按Enter鍵。 您將看到計數結果顯示在所選單元格中。

在Excel中輕鬆計算兩個值或日期之間的單元格數:

點擊 庫工具 > 選擇 > 選擇特定的單元格。 “ Kutools for Excel's 選擇特定的單元格 實用程序可幫助您輕鬆計算和選擇Excel中兩個值或日期之間的單元格。
立即下載Kutools for Excel的全功能30天免費試用版!


使用CountIf函數計算兩個日期之間的單元格編號

在本節中,我們向您展示如何根據單元格引用對兩個日期之間的單元格計數。

例如,工作表中單元格A14:A20中存在的日期範圍,並且您要基於單元格B21和B22計算單元格號,請執行以下操作。

1.選擇一個空白單元格,複製並粘貼公式 =COUNTIFS(A14:A20,">="&B21,A14:A20,"<="&B22) 進入公式欄,然後按Enter鍵。 請參見下面的屏幕截圖。

備註:複製並粘貼上面的公式後,您需要根據自己的需要手動更改單元格範圍和值。


使用Kutools for Excel(沒有公式)計算兩個值或日期之間的單元格編號

如果您是公式新手並且不能輕鬆處理公式,建議您使用一個方便的加載項,以輕鬆計算Excel中兩個值或日期之間的單元格數。

申請前 Kutools for Excel首先下載並安裝.

步驟1。 點擊 庫工具 > 選擇 > 選擇特定的單元格.

doc計算兩個值之間的單元格編號9

步驟2。 在裡面 選擇特定的單元格 對話框中,在 選擇此範圍內的單元格 部分,選擇 細胞 在選項 選擇類型 部分,指定您的條件,例如 比...更棒 75和 小於 在90中 特定類型 部分,最後點擊 Ok 按鈕。

步驟3.然後 選擇特定的單元格 彈出對話框,顯示滿足上面指定條件的單元格總數,單擊 OK 按鈕,並立即選擇單元格。

備註:使用此功能,您還可以計算並選擇兩個日期之間的日期,只需要將兩個日期輸入到 選擇特定的單元格 對話框如下圖所示:

  如果您想免費試用該工具(30天), 請點擊下載,然後按照上述步驟進行操作。


演示:用Kutools for Excel在兩個值或日期之間計算單元格數


相關文章:


最佳辦公效率工具

Kutools for Excel解決了您的大多數問題,並使您的生產率提高了80%

  • 重用: 快速插入 複雜的公式,圖表 以及您以前使用過的任何東西; 加密單元 帶密碼 創建郵件列表 並發送電子郵件...
  • 超級公式欄 (輕鬆編輯多行文本和公式); 閱讀版式 (輕鬆讀取和編輯大量單元格); 粘貼到過濾範圍...
  • 合併單元格/行/列 不會丟失數據; 拆分單元格內容; 合併重複的行/列...防止細胞重複; 比較範圍...
  • 選擇重複或唯一 行; 選擇空白行 (所有單元格都是空的); 超級查找和模糊查找 在許多工作簿中; 隨機選擇...
  • 確切的副本 多個單元格,無需更改公式參考; 自動創建參考 到多張紙; 插入項目符號,複選框等...
  • 提取文字,添加文本,按位置刪除, 刪除空間; 創建和打印分頁小計; 在單元格內容和註釋之間轉換...
  • 超級濾鏡 (將過濾方案保存並應用於其他工作表); 高級排序 按月/週/日,頻率及更多; 特殊過濾器 用粗體,斜體...
  • 結合工作簿和工作表; 根據關鍵列合併表; 將數據分割成多個工作表; 批量轉換xls,xlsx和PDF...
  • 超過300種強大功能。 支持Office / Excel 2007-2019和365。支持所有語言。 在您的企業或組織中輕鬆部署。 完整功能30天免費試用。 60天退款保證。
kte選項卡201905

Office選項卡為Office帶來了選項卡式界面,使您的工作更加輕鬆

  • 在Word,Excel,PowerPoint中啟用選項卡式編輯和閱讀,發布者,Access,Visio和Project。
  • 在同一窗口的新選項卡中而不是在新窗口中打開並創建多個文檔。
  • 每天將您的工作效率提高50%,並減少數百次鼠標單擊!
officetab底部
按評論排序
留言 (5)
還沒有評分。 成為第一位評論!
網站主持人對此評論進行了最小化
編號學生性別 姓名 姓名 加入日期 1 ABC ananthi f 01-05-2015 2 DEF arjun m 21-05-2015 3 ABC reshma f 22-06-2015 4 DEF rani f 07-07-2015 5 CAD gopika f 08- 07-2015 6 CAD banu f 25-07-2015 7 ABC vijay m 22-08-2015 8 ABC ARUN M 05-08-2015 我想計算學校名稱 ABC 以及從 01 年 06 月 2015 日起有多少男性或女性到 31-08-2015 幫助我計算日期之間特定日期內的文本 [b] 這種類型是我需要的輸出,從 01-06-2015 到 31-08-2015 學校名稱 男性 女性 ABC 2 1
網站主持人對此評論進行了最小化
Hi

有很多方法可以做到這一點,但如果你有上面提到的數據,那就很容易了。

所有你需要做的就是
1.選擇列
2.從功能區的數據選項中轉到“文本到列”
3.按空格分隔數據
4. 相應地進行操作。
網站主持人對此評論進行了最小化
alguien me puede ayudar con esta 公式 =SUMAPRODUCTO(--(BD!AY9:AY32>=SNIS!AI6); --(BD!AY9:AY32<=SNIS!AL6);
--(CONTAR.SI.CONJUNTO(BD!C9:C32;">=0,6";BD!C9:C32;"<=1"))) donde esta el 錯誤
網站主持人對此評論進行了最小化
如何計算屬於相同文本描述的單元格。 例如:傑伊、邁克和亞歷克斯通過了這個題目。 然後 EXCEL 數一數。 但他們的名字出現了很多次
很像
這裡還沒有評論
留下你的意見
以訪客身份發帖
×
評價此帖子:
0  字符
推薦地點