Note: The other languages of the website are Google-translated. Back to English

如何在Excel中進行生日提醒?

也許您的企業中有成千上萬的員工,在他們的生日那天,您想向他們發送一張生日賀卡,上面寫著您的願望。 他們的姓名,出生和其他詳細信息都列在工作表中,您怎麼知道今天是誰的生日? 以及如何在Excel中進行生日提醒?

使用公式在Excel中進行生日提醒

使用條件格式在Excel中進行生日提醒


箭頭藍色右氣泡 使用公式在Excel中進行生日提醒

以下公式可以為生日是今天的人打分。 您可以按照以下步驟處理此問題:

1。 假設您擁有員工的以下信息。

文檔製作生日提醒 1

2。 請輸入或複制此公式 = IF(MONTH(B2)<> MONTH(TODAY()),“” ,, IF(DAY(B2)<> DAY(TODAY()),“”,“生日快樂”)) (B2 是包含生日日期的單元格,您可以根據需要將其更改為一個空白單元格C2。

文檔製作生日提醒 1

3。 然後按 Enter 鍵,然後選擇單元格C2並將填充手柄拖動到要應用此公式的範圍。 如果日期符合條件,它將在單元格中顯示“生日快樂”,但如果日期不符合條件,則將顯示空白單元格。 看截圖:

文檔製作生日提醒 1

備註:此公式是動態的,結果將隨著時間的變化而改變,因此您可以快速查看今天是誰的生日。


箭頭藍色右氣泡 使用條件格式在Excel中進行生日提醒

除了使用上面的公式,您還可以應用條件格式來在B列中突出顯示今天的生日。

1。 在B列中選擇所有日期。

2。 然後點擊 首頁 > 條件格式 > 新規則,請參見屏幕截圖:

文檔製作生日提醒 1

3。 而在中 新格式規則 對話框中單擊 使用公式來確定要格式化的單元格 選項下 選擇規則類型 部分,然後輸入此公式 =(MONTH(TODAY())= MONTH(B2))*(DAY(TODAY())= DAY(B2)) 格式化此公式為真的值 領域。 (B2 是您的日期範圍內的第一個活動單元格)查看屏幕截圖:

文檔製作生日提醒 1

4。 然後點擊 格式 按鈕去 單元格格式 對話框,然後單擊 標籤,然後選擇您喜歡的一種顏色。

文檔製作生日提醒 1

5. 然後點擊 OK > OK 關閉對話框,生日是今天,突出顯示如下:

文檔製作生日提醒 1

備註:此條件格式也是一種動態方式,結果將隨著時間的變化而改變,因此您可以快速查看今天是誰的生日。


相關文章:

如何在Excel中快速將出生日期轉換為年齡?

如何在Excel中按月快速排序生日(日期)?


最佳辦公效率工具

Kutools for Excel 解決了你的大部分問題,並將你的生產力提高了 80%

  • 重用: 快速插入 複雜的公式,圖表 以及您以前使用過的任何東西; 加密單元 帶密碼 創建郵件列表 並發送電子郵件...
  • 超級公式欄 (輕鬆編輯多行文本和公式); 閱讀版式 (輕鬆讀取和編輯大量單元格); 粘貼到過濾範圍...
  • 合併單元格/行/列 不會丟失數據; 拆分單元格內容; 合併重複的行/列...防止細胞重複; 比較範圍...
  • 選擇重複或唯一 行; 選擇空白行 (所有單元格都是空的); 超級查找和模糊查找 在許多工作簿中; 隨機選擇...
  • 確切的副本 多個單元格,無需更改公式參考; 自動創建參考 到多張紙; 插入項目符號,複選框等...
  • 提取文字,添加文本,按位置刪除, 刪除空間; 創建和打印分頁小計; 在單元格內容和註釋之間轉換...
  • 超級濾鏡 (將過濾方案保存並應用於其他工作表); 高級排序 按月/週/日,頻率及更多; 特殊過濾器 用粗體,斜體...
  • 結合工作簿和工作表; 根據關鍵列合併表; 將數據分割成多個工作表; 批量轉換xls,xlsx和PDF...
  • 超過 300 項強大的功能. 支持 Office / Excel 2007-2021 和 365。支持所有語言。 在您的企業或組織中輕鬆部署。 完整功能 30 天免費試用。 60 天退款保證。
kte選項卡201905

Office選項卡為Office帶來了選項卡式界面,使您的工作更加輕鬆

  • 在Word,Excel,PowerPoint中啟用選項卡式編輯和閱讀,發布者,Access,Visio和Project。
  • 在同一窗口的新選項卡中而不是在新窗口中打開並創建多個文檔。
  • 將您的工作效率提高 50%,每天為您減少數百次鼠標點擊!
officetab底部
按評論排序
留言 (8)
還沒有評分。 成為第一位評論!
網站主持人對此評論進行了最小化
我想創建一個程序,讓部門負責人在到期時(比如 10 天)收到一封電子郵件,當日期是一天或超過到期日期時,可能會顯示顏色,第二次按摩說可能需要調解乙偶姻RED 這將有助於使部門遠離麻煩。 我是一個工具,這真的很困難 Ken Billingham Khb2@msn.com
網站主持人對此評論進行了最小化
我想創建一個程序,讓部門負責人在到期時(比如 10 天)收到一封電子郵件,當日期是一天或超過到期日期時,可能會顯示顏色,第二次按摩說可能需要調解乙偶姻RED 我是一個工具,這真的很困難 Ken Billingham Khb2@msn.com
網站主持人對此評論進行了最小化
不喜歡收到 Excel 格式的客戶生日通知
網站主持人對此評論進行了最小化
Не верная твоя формула!
她看起來像這樣:
=ЕСЛИ(МЕСЯЦ(F16)=МЕСЯЦ(СЕГОДНЯ());ЕСЛИ(ДЕНЬ(F16)=ДЕНЬ(СЕГОДНЯ());"СДнем Рождения";0))
網站主持人對此評論進行了最小化
你好,
本文中的公式適用於英語,您的公式適用於您的語言。
也許你的公式可以幫助別人,謝謝!
網站主持人對此評論進行了最小化
我注意到你們所有的 Excel 公式都很棒,雖然有些可以在 Google Docs 電子表格中使用,但許多需要稍微編輯一下。 將來您還可以為 Google 電子表格添加一些內容嗎? (對於初學者來說,出生日期是一個,我無法弄清楚。)
網站主持人對此評論進行了最小化
,您好!
hai trovato la formula per caso ?
網站主持人對此評論進行了最小化
你好,德韋恩

我們文章中的第一個公式在 Google 表格中運行良好。
如果你想使用條件格式來完成它,在谷歌表格中的條件格式中輸入以下公式:
=和(月(B1:B15)=月(今天()),天(B1:B15)=天(今天()))

請試一試,希望對您有所幫助!
這裡還沒有評論
留下你的意見
以訪客身份發帖
×
評價此帖子:
0   字符
推薦地點

關注我們

版權所有©2009 - 萬維網。extendoffice.com。 | 版權所有。 供電 ExtendOffice。 |
Microsoft和Office徽標是Microsoft Corporation在美國和/或其他國家的商標或註冊商標。
受Sectigo SSL保護